Commit 9d09fb7f authored by Jérome Perrin's avatar Jérome Perrin

setup: define test dependencies with extras_require

tests_require is only supported by setuptools' test entry point which is
deprecated, extras_require is supported by most tools.
parent a5957c8d
Pipeline #12348 passed with stage
in 0 seconds
......@@ -29,10 +29,12 @@ setup(name=name,
'setuptools',
'slapos.recipe.build',
],
tests_require=[
'mock',
'pathlib',
],
extras_require={
'test': [
'mock',
'pathlib',
],
},
entry_points={
'zc.buildout': ['default = rubygems:Recipe']
},
......
......@@ -11,3 +11,4 @@ commands = python setup.py nosetests
deps =
coverage==3.7.1
nose==1.3.4
extras = test
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment